Bachmann EZ command reset?


New Member
I have been using EZ command with success for 3 years. Recently, I added a walk around companion throttle. It worked flawlessly when connected directly to the controller. I wanted to operate from another location on the layout so I purchased the remote connector panel (with cable). I installed it according to directions (although quite simple) and plugged in across the layout. Some of the locomotives worked, but the forward direction light did not light any longer (locos still run) and several of locos didn't light up or run. I tried plugging the companion back into the controller directly and still have problems as described above. I tried powering everything off, unplugging and plugging, etc. I also tried the second port for the IO connection. No luck.
Is there a reset for the controller or companion. The controller still works fine by itself.
Thanks for any help you may provide.
from the Oregon River and Beaver Junction Railroad (based on the MRR beer line from 2009)
Either take all the loco's off the track except one or put it on a programming track then follow the manual directions for resetting a loco address. Sounds like their addressing has become corrupted. The same thing happened to me (though not as extensively) and that's how I fixed it.
complete reprogamming had no effect

I removed all the locomotives. Re-programmed each one to the same address as before. All functioning normally with ez command controller. plugged the walkaround throttle back in (as per instructions) and had same result. It will run 3 of the 9 locomotives. functions (lights, horns, bells) working okay on the 3. forward direction light still doesn't come on. and the other addresses don't light up (six locos). very strange. tried every combination of cabling. same result. straight from controller to throttle (bypassing new companion port), same result.
any more ideas? I may try reprogramming locos to different addresses next.
thanks for your help.
Do you have all nine of the locos on powered track at the same time? The EZ-Command only has one amp. A loco that's just sitting on powered track is still taking power away from that one amp. Remove the extra locos or move them to track that can be turned off and see what happens.
ez command extra throttle problem

Hi dr,
No, I'm not running 9 at once. The most I really run is 3-4, and the system handles that okay. My layout is 4X11, with lots of feeder wires and good power distribution. Thanks for the reply.