Digitrax DT602D Throttle Doesn't Work

ModelRailroadForums.com is a free Model Railroad Discussion Forum and photo gallery. We cover all scales and sizes of model railroads. Whether you're a master model railroader or just getting started, you'll find something of interest here.


D&J RailRoad

Professor of HO
I think the QC wasn't payin attention when this unit came down the assembly line. Seems it was a quick fix on Digitrax part.
I was running it last night for a little bit. No problems found. The features are a bit different from the 400 and 500 series throttles, but then, that's progress.
I would like to get ahold of one of the new UR93 receivers. It's only available with the new command station. The slick sheet on it says the signal is at least double that of the UR92 so it has greater coverage.
 

D&J RailRoad

Professor of HO
Well that didn't last long. Now this DT602D throttle is acting all quirky again. It doesn't see the UR92 receiver despite being about 6 feet from it. When it's plugged into the loconet, parts of the screen flicker different messages to fast to read, then flickers the information about battery power external power or something like that. The battery icon in the top right is going from completely depleted back up to full.
I checked my system with a couple other throttles and they all worked fine, so obviously its the DT602D. Digitrax says they did the fix on the repair ticket but obviously didn't test this. In the mean time, I gotta spend postage and time sending this to them again.
Real piece of work there Digitrax. At least ya got it out the door and got my money, right?
 
Last edited:

D&J RailRoad

Professor of HO
OK, been messing with this all afternoon and finally found the problem. The DT602D was not syncing up to my system when I plugged it into the loconet. My channel was set on 26 but the DT602D would only stay on channel 11, so it couldn't communicate with my system. I changed my UR92 to channel 11 then plugged the DT602D back into the loconet and it came up with my system name and was still showing channel 11. It could run trains and all functions now.
 

D&J RailRoad

Professor of HO
More problems are cropping up with the DT602D Digitrax throttle.
The F2 button blows the horn or whistle. On some of my locos, the 2 stays illuminated on the header of the throttle and the whistle continues to blow until I hold the F2 button down. When I let up on the button, the whistle blows. I dial up another locomotive and it works correctly.
When the F2 stays latched down, I have to turn off the throttle then reboot it to make the whistle stop, until I push the F2 button again.
I'm seeing other people are having this same problem on their 602 throttle. Obviously this throttle wasn't tested for more than a few minutes by Digitrax.
 

D&J RailRoad

Professor of HO
Still having problems with the DT602D. Downloaded and installed the latest firmware of 14 Aug 2020 REV .02 The throttle still doesn't hold a MU consist of locos. Tested it against a DT502D and it had no problems. Dispatched back to the DT602D and only the lead loco would run.
This throttle is going back to Digitrax for a refund.
 

D&J RailRoad

Professor of HO
It's quite obvious this wasn't thoroughly tested prior to public release.
Puzzling though that there are others on the Digitrax board who are reporting no problems with their throttle. Don't know if its a difference in command stations or possibly the assembly lines each throttle came through. Either way, I've done my time with this one and want to send it back.
 

Alcomotive

Grandson of ALCO Bldr
It's quite obvious this wasn't thoroughly tested prior to public release.
Puzzling though that there are others on the Digitrax board who are reporting no problems with their throttle. Don't know if its a difference in command stations or possibly the assembly lines each throttle came through. Either way, I've done my time with this one and want to send it back.

Ken,

I don't blame you! I would send it back and get my $ as well. I personally have a practice with all things that are new and come out....to wait until a minimum of 1 year. I usually let the first crowds deal with the bugs lol. I am same with vehicles too. Nothing ticks me off more than a new product that says it does something and it doesn't. Not bashing Digitrax but all companies in general. I have Digitrax and plan stay with what works for my layout. At this time my temp layout doesn't warrant a new upgrade. Although when I do my new layout in my new garage extension then I will consider it.
 




Affiliate Disclosure: We may receive a commision from some of the links and ads shown on this website (Learn More Here)


ModelRailroadForums.com is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com

RailroadBookstore.com - An online railroad bookstore featuring a curated selection of new and used railroad books. Railroad pictorials, railroad history, steam locomotives, passenger trains, modern railroading. Hundreds of titles available, most at discount prices! We also have a video and children's book section.

ModelRailroadBookstore.com - An online model railroad bookstore featuring a curated selection of new and used books. Layout design, track plans, scenery and structure building, wiring, DCC, Tinplate, Toy Trains, Price Guides and more.

Top