Swapping decoders

ModelRailroadForums.com is a free Model Railroad Discussion Forum and photo gallery. We cover all scales and sizes of model railroads. Whether you're a master model railroader or just getting started, you'll find something of interest here.


RCShadow

Member
LOL! Too funny toot.

To set this bit...

For example:

The default value for CV49, Headlamp control is 15, but change this to 2 for a Mars light. The effect is there, but not very vibrant with an LED, as you’d expect. Add in 128 (128+2=130) into CV49 and look at the mars light now.

Adding 128 to the settings is the key here. I hope that makes more sense?? This sets bit 7 in the decoder by adding 128 to the setting value. This does not change the output voltage to regulate for LEDs, so resistors are still required it just changes the way the decoder handles the effect so it looks better with an LED.
 
Last edited by a moderator:

tootnkumin

Well-Known Member
Staff member
I didn't tell you that the first time I had my hands on a DCC control was a couple of weeks ago at my new club and then I was only on the test track, haha. At least I'm now at the right club to get help.
 

RCShadow

Member
I didn't tell you that the first time I had my hands on a DCC control was a couple of weeks ago at my new club and then I was only on the test track, haha. At least I'm now at the right club to get help.
No worries.

My problem with this DCC stuff is that not only were they designed by electrical engineers but the manuals must have been written by the same guys. It's confusing to be sure. The DCC manufacturers need to hire tech writers that can actually present material to an audience that doesn't confuse the hell out of everyone involved. I had to do several searches on the net to finally come up with instructions I could understand when I first started. Believe me, it's not you, it's the material.

To me, my NCE system should be as sinple as "Enable LED lights for this output (Y/N)?". Then internally add the 128 to the value. DUH!
 
Last edited by a moderator:

tootnkumin

Well-Known Member
Staff member
No worries.

My problem with this DCC stuff is that not only were they designed by electrical engineers but the manuals must have been written by the same guys. It's confusing to be sure. The DCC manufacturers need to hire tech writers that can actually present material to an audience that doesn't confuse the hell out of everyone involved. I had to do several searches on the net to finally come up with instructions I could understand when I first started. Believe me, it's not you, it's the material.

To me, it could be a simple "Enable LED lights for this output (Y/N)?". Then internally add the 128 to the value. DUH!
I'm going to copy and print out your post so I can have it on hand when I start getting properly into this. Have had an NCE 5amp Power Pro sitting in storage ready for action (it's me that needs to pull finger). Will set myself up a couple of lengths of flex as a programming track which I can sit across my computer desk and look into downloading JMRI. Had 2 of my locos registered and set-up at the club and watched as it was done so here's hoping.
 

RCShadow

Member
I'm going to copy and print out your post so I can have it on hand when I start getting properly into this. Have had an NCE 5amp Power Pro sitting in storage ready for action (it's me that needs to pull finger). Will set myself up a couple of lengths of flex as a programming track which I can sit across my computer desk and look into downloading JMRI. Had 2 of my locos registered and set-up at the club and watched as it was done so here's hoping.
Yep. I have a piece of flex track just for programming. I don't have the Pro version of the NCE but the Power Cab with an SB5 booster so I got five amps. Since my layout is up so high, and the fact that the SB5 doesn't have a "programming track" mode, made me set up the programming part by itself. There have been too many times I needed to reset loco's too and it comes in handy.

Just dive in and give it a try. The worst you will have to do is reset the loco back to factory settings if it gets messed up. Just remember CV 8 to value 8 to reset. You will know the loco is reset because the headlight will flash 16 times when you apply track power to it again. And remember the loco number will be reset to a value of 3.
 
Last edited by a moderator:

PaulB

Member
They will light LEDs no problem. Just wire the positive leads all to the whole marked "14v" and put 1000 ohm resistors on the function pads on the decoder and solder the negative leads to thm. Done, never burn out, 5000+ hours of use.

I am glad to read that. The DCC ready GP-9's in the livery I want are getting thin on the ground but the sound equipped are still available in number. That is a big releif to know I can just rewire the existing Athearn/tsunami set up. Wouldn't want to waste money.
 




Affiliate Disclosure: We may receive a commision from some of the links and ads shown on this website (Learn More Here)


ModelRailroadForums.com is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com

RailroadBookstore.com - An online railroad bookstore featuring a curated selection of new and used railroad books. Railroad pictorials, railroad history, steam locomotives, passenger trains, modern railroading. Hundreds of titles available, most at discount prices! We also have a video and children's book section.

ModelRailroadBookstore.com - An online model railroad bookstore featuring a curated selection of new and used books. Layout design, track plans, scenery and structure building, wiring, DCC, Tinplate, Toy Trains, Price Guides and more.

Top