EZ Track and Control Blocks



I am attempting to create control blocks with EZ track. Now I’m stuck looking for help.

I purchased Atlas insulated rail joiners and left the outside track as my common track. Also purchased an Atlas selector.

Then I did the following.

I have three control blocks. I used EZ track terminal tracks to provide power. Block number one had the return wire, I removed the return wire from blocks two and three. I connected block one to an Atlas Selector and the return wires from Cab A and B. The wire attached to the selector from block 1 is the left wire in terminal, the right wire is the common rail return wire.

I then wired the reaming wires from blocks 2 and 3 to the selector. Looking at the terminal this would be the left connector.

Looking at the Cab's the right side screw is the return and the left goes to the Selector.

So here is what happened when I turned it on, block one ran fine, as soon as I hit block's 2 or 3, the train stops when the front wheels entered the new block. So, then I flipped the connector into the terminal in blocks 2 and 3 and the train ran until the back wheels were in the block and then stopped. I then flipped the wires into block one, no good. I tried both cabs and got the same results.

So far, I have checked all my connections, I have checked again and without blocks it runs fine. I reconnected the blocks, same thing. I think my problem may be in how I joined my return wires, the three wires, one from block one and one from each cab. All I did was twist them together, I'm not sure if I was supposed to do anything else. Of course block one works with both cabs, so maybe that’s not it. I verified that I isolated the correct rails.

So, now I am appealing to all of you. HELP.

and thanks in advance.
Sorry didn't get to this before, but you must have had a couple polaritys mixed up so when the loco crossed the gap it caused a short cct. Glad you got it all worked out, believe me it happens to the best also. :D

Cheers Willis